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Items highlighted in yellow are tasks for you to complete

Items in Blue italics are help tips

These pages are designed to show you how to use software packages; various software updates may have taken place so some pages will not apply to versions other than those listed here. In some cases data files may be required.

Introducing Flash Toolbars Environment

The Flash environment

The opening area is called the stage here is where you can assemble your text or symbols – you can use the gray area to bring items in or move them out as you determine.
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If you need help just ask!
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Flash Properties for Text
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Font



Size

Colour

Styles

Alignment

You will import four pictures and move them to other locations to create an animated effect.

Later you can experiment with rotating and reshaping your pictures.
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Timeline Area Explained

The Toolbar


Arrow Tool (Move items)
Subselect Tool 

Line Tool


Lasso

Pen Tool


Text Tool

Circle Tool


Rectangle Tool

Pencil



Brush

Free Transform Tool

Fill Transform Tool

Ink Can (Lines)

Paint Bucket

Eyedropper (Selects)

Eraser

Hand Tool (Move)

Zoom + or  (Alt Opt -)

Stroke (Line) Colour


Fill (Solid) Colour

Black & White

Swap Colours

Snap To Option

Smooth Line


Straighten Line


The drawing tools in Flash let you create and modify shapes for the artwork in your movies. For an interactive introduction to drawing in Flash, choose Help > Lessons > Drawing in your Flash program. 

The tools for painting are kept in the "Tools" bar, usually positioned at the left top of your Flash Screen.
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On the following pages we will guide you through the use of each of these tools, starting with the simplest.

But before going through the different tools, we will look at the way Flash handle drawings.

The most important thing to understand is the distinction between outlines and fills.

When you draw a line there is no fill - only the outline.

When you draw a rectangle (or a circle) you actually draw two things: The outline (border) and the fill. Unlike most other programs, Flash doesn't automatically combine these two into one object
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The Pencil tool is used in much the same way that you would use a real pencil to draw. Simply select the tool and drag on the Stage to draw with the Pencil tool. 




SHIFT key : Constrain directions

You can press the Shift key while dragging to constrain lines to vertical or horizontal directions. 




Colors

You can specify the color with the Stroke Color Tool.

Color Tools:
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Smoothing and Straightening

You can apply smoothing or straightening to the lines by setting a Pencil mode.

Pencil Modes:
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Stroke panel : Window > Panels > Stroke

Finally, you can specify line style (solid, dotted etc.), line width in pixels and color using the Stroke panel.

Stroke Panel:
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The Brush tool draws brushlike strokes, as if you were painting. It lets you create special effects, including calligraphic effects.

Unlike the Pencil tool, the Brush tool draws both a fill and an outline. 




SHIFT key : Constrain directions

You can press the Shift key while dragging to constrain drawing to vertical or horizontal directions. 




Colors

You can specify the color with the Stroke and Fill Color tools.

Color Tools:
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Brush Modes

You can specify the Brush Mode in order to define the way the tool works:

· Paint Normal - paints over lines and fills on the same layer.
· Paint Behind - paints in blank areas of the Stage on the same layer, leaving lines and fills unaffected.

· Paint Selection - applies a new fill to the selection when you select a fill in the Fill modifier or the Fill panel. (This option is the same as simply selecting a filled area and applying a new fill.)

· Paint Fills - paints fills and empty areas, leaving lines unaffected.

· Paint Inside - paints the fill in which you start a brush stroke and never paints lines. This works much like a smart coloring book that never allows you to paint outside the lines. If you start painting in an empty area, the fill doesn't affect any existing filled areas.


Brush Modes:
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NONE | NORMAL | BEHIND | SELECTION | FILLS | INSIDE



Brush Size

Also, in the Brush options, there is a drop down that lets you select the size of the brush. Simply click the size you want.




Brush Shape

Finally, the Brush options lets you select the shape of the brush. Try experimenting with the different shapes and see what effect each offers.




Lock Fill

The last option listed under Brush options, is the Lock Fill option. The explanation for this is a bit tricky.

When you use the brush tool in it's default state this option is not turned on. Let's assume that you selected a gradient fill and painted something using the brush tool. In this case the brush tool would use the center of your painting as the center for the gradient fill.

Now, if you paint yet another drawing next to the first one, Flash will use the new drawing's center as center for the gradient fill.

However, had you pressed the "Lock Fill" option before drawing the second painting, Flash will maintain the gradient center from the first painting.

The best way to understand this option is trial and error, so if you don't get the above explanation, then try painting with and without the "Lock Fill" option set. While doing so, make sure that you use a gradient fill for the drawing or you won't see any effect at all (because plain colored fills have no center).
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The Line tool is used in much the same way that you would use a real pencil to draw with a ruler. Simply select the tool and drag on the Stage to draw a straight line between the start and end points. 




SHIFT key : Constrain angles

You can press the Shift key while dragging to constrain possible angles for the line. By default this will only allow for lines that are either horizontal, vertical or 45 degrees between.




Colors

You can specify the color with the Stroke Color Tool.

Color Tools:
[image: image21.png]Stroke color

Fill color

L)

‘Swap stroke and fll button
None button
DBetauk stroke and fill button








Curving

You can turn a straight line into a curve with the Arrow tool [image: image22.png]




1: Make sure the line is not selected (you can do this by clicking somewhere on an empty spot on the stage).

2: Select the Arrow tool.

3: Click on the line, and while holding down the mouse button, drag the curve.

4: Release the mouse button and your curve is finished.

Curving Lines and Edges:
[image: image23.png]






Moving

You can move a line with the mouse, quite similar to how you'd turn it into a curve or you can move it with the arrow keys. 

1: Select the Arrow tool.

2: Make sure the line is selected (you can do this by clicking once on the line then release the mouse button).

3a: Click on the line, and while holding down the mouse button, move it to the new position.

3b: Press the arrow keys on your keyboard to move the line.




Precise size and positioning

You can position the line perfectly by using the info panel.

Info Panel : Window > Panels > Info
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The "square" connected to the line where it says "Click this square" is used to set the origin for coordinates - either at top left or center of the stage.

Fields for X and Y are used to enter the position of the selected object. 

Fields for W and H are used to enter the width and height of the selected object.

When working with lines, one might think that height would be 1 for a thin line. However, width and height refers to the square between the start and end points of the selected object. 
A horizontal line that is 100 pixels wide and 1 pixel high spans a square of 100 x 1 pixels.
A similar line would span a square of 100 x 100 pixels if it was turned 45 degrees.
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The Oval tool is used to make circular objects. Simply select the tool and drag on the Stage to draw a circle that spans between the start and end points. 




SHIFT key : Round Circles

You can press the Shift key while dragging to ensure your circle is perfectly round.



Colors

You can specify the colors with the Stroke and Fill Color Tools.

Color Tools:
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Ctrl+G : Grouping Outline with Fill

When you draw a circle, Flash actually creates two objects: the fill and the outline. This may cause problems if you try to move your circle to a new position, because if you fail to select both objects, only the one selected will be moved. To avoid this it's often a good idea to "group" the outline with the fill, thus locking them together as if it was a single object.

1: Make sure both the fill and the outline is selected.
(You can do this in two ways: 1) Select the Arrow tool in the toolbox, and while holding down the SHIFT key click on both the fill and the outline. 2) Select the Arrow tool in the toolbox, and drag a rectangle outside your circle)

2: Press Ctrl+G to group the selected objects.

(If at a later point you want to "break" apart the grouped objects, you can do it by selecting the grouped object then pressing Ctrl+B).




Precise size and positioning

You can position the oval perfectly using the info panel.

Info Panel : Window > Panels > Info
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The "square" connected to the line where it says "Click this square" is used to set the origin for coordinates - either at top left or center of the stage.

Fields for X and Y are used to enter the position of the selected object. 

Fields for W and H are used to enter the width and height of the selected object.
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The Rectangle tool is used to make rectangular objects. Simply select the tool and drag on the Stage to draw a rectangle that spans between the start and end points. 




SHIFT key : Proportioned Squares

You can press the Shift key while dragging to constrain proportions for the rectangle, to ensure your rectangle is a perfect square.




Colors

You can specify the colors with the Stroke and Fill Color Tools.

Color Tools:
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Rounded Corners

You can specify the rounding of the corners with the "Round Rectangle Options" at the bottom of the toolbox.




Ctrl+G : Grouping Outline with Fill

When you draw a rectangle, Flash actually creates two objects: the fill and the outline. This may cause problems if you want to move your rectangle to a new position, because if you fail to select both objects, only the one selected will be moved. To avoid this it's often a good idea to "group" the outline with the fill, thus locking them together as if they were a single object.

1: Make sure both the fill and the outline are selected.
(You can do this in two ways: 1) Select the Arrow tool in the toolbox, and while holding down the SHIFT key click on both the fill and the outline. 2) Select the Arrow tool in the toolbox, and drag a rectangle outside your rectangle)

2: Press Ctrl+G to group the selected objects.

(If at a later point you want to "break" apart the grouped objects, you can do it by selecting the grouped object then pressing Ctrl+B).




Skewing

Before skewing a rectangle make sure it has been grouped. You can skew the rectangle in two ways. 

To skew an object by dragging:

1. Select the object with the Arrow tool. 
2. Click the Rotate button in the toolbox options.
3. Drag one of the centered handles. 
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To skew an object using the Transform panel:

1. Select the object. 
2. Choose Window > Panels> Transform. 
3. Click Skew.
4. Enter angles for the horizontal and vertical values. 
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Precise size and positioning

You can position the Rectangle perfectly using the info panel.

Info Panel : Window > Panels > Info
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The "square" connected to the line where it says "Click this square" is used to set the origin for coordinates - either at top left or center of the stage.

Fields for X and Y are used to enter the position of the selected object. 

Fields for W and H are used to enter the width and height of the selected object.
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The Erase tool works similar to a classic eraser. Simply select the tool and drag on the Stage to erase things. 



Double-click Eraser Tool: Erase All

You can double click the Eraser tool to delete everything on the stage. (If you happen to do this by mistake you can always click Ctrl+Z to undo).




[image: image36]Using the Eraser Mode Option

In the options listed at the bottom of the toolbox you can specify the Eraser Mode:

· Erase Normal - erases strokes and fills on the same layer.
· Erase Fills - erases only fills; strokes are not affected.

· Erase Lines - erases only strokes; fills are not affected.

· Erase Selected Fills - erases only the currently selected fills and does not affect strokes, selected or not. (Select the fills you want to erase before using the Eraser tool in this mode.)

· Erase Inside - erases only the fill on which you begin the eraser stroke. If you begin erasing from an empty point, nothing will be erased. Strokes are unaffected by the eraser in this mode.
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Using the Faucet Option

To remove stroke segments or filled areas: 

1. Select the Eraser tool and then click the Faucet modifier. 

2. Click the stroke segment or filled area that you want to delete. 
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Using the Eraser Shape Option

In the options listed at the bottom of the toolbox there is a drop down that lets you specify the Eraser shape and size.
Use this option to customize the size and look of the eraser.




Alternative ways to delete things

There are other ways to delete things besides using the Eraser tool.

The most common way is to select one or more objects and then press the DEL key on the keyboard.

You can delete an entire layer by clicking the layer at the top of your screen and dragging it to the Trash bin.

You can delete several frames at once by selecting the frames (and layers) in the timeline, then right click and choose "cut frames".
[image: image39.png]




The Ink Bottle tool lets you change the stroke color, line width, and style of lines or shape outlines. 

Using the Ink Bottle tool, rather than selecting individual lines and objects, makes it easier to change the stroke attributes of multiple objects at one time.




To use the Ink Bottle tool:

1. Select the Ink Bottle tool. 

2. Choose a stroke color as described in Using the Stroke and Fill controls in the toolbox. 

Color Tools:
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3. Choose line style and line width from the Stroke panel. 

Stroke Panel : Window > Panels > Stroke
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4. Click an object on the Stage to apply the stroke modifications. 




Applying outlines to existing objects:

You can use the stroke tool to apply outlines even for things that were initially made without outlines.
For example, if you initially created a rectangle with no outline, then later decided you wanted an outline, simply use the Ink Bottle tool as described above and a new outline will be applied.
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The Paint Bucket tool fills enclosed areas with color. 

It can both fill empty areas and change the color of already painted areas. 

You can paint with solid colors, gradient fills, and bitmap fills. 

You can also use the Paint Bucket tool to adjust the size, direction, and center of gradient and bitmap fills.




To use the Paint Bucket tool to fill an area: 

1. Select the Paint Bucket tool. 

2. Choose a fill color from the color tool box.

Color Tools:
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3. Click the Gap Size modifier [image: image45.png]


and choose a gap size option:

· Don't Close Gaps : if you want to close gaps manually before filling the shape. Closing gaps manually can be faster for complex drawings. 
· Choose one of the Close options to have Flash fill a shape that has gaps.


4. Click the shape or enclosed area that you want to fill. 





To adjust a gradient or bitmap fill with the Paint Bucket tool:

1. Select the Paint Bucket tool. 

2. Click the Transform Fill [image: image46]. 

3. Click an area filled with a gradient or bitmap fill. 
Depending on the type of object you're painting you will see different handles:


a. Transform Linear Gradient Fills
[image: image47.png]


.

b. Transform Radial Gradient Fills
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.

c. Transform Bitmap Fills
[image: image49.png]


.

4. Reshape the fill in any of the following ways: 

a. To reposition the center point, drag the center point. 
[image: image50.png]




b. To change the width of the fill, drag the square handle on the side of the bounding box. (This option resizes only the fill, not the object containing the fill.) 
[image: image51.png]




c. To change the height of the fill, drag the square handle at the bottom of the bounding box. 
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d. To rotate the fill, drag the circular rotation handle at the corner. You can also drag the lowest handle on the bounding circle of a circular gradient or fill. 
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e. To scale a linear gradient, drag the square handle at the center of the bounding box. 
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f. To change the radius of a circular gradient, drag the middle circular handle on the bounding circle. 
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g. To skew or slant a fill within a shape, drag one of the circular handles on the top or right side of the bounding box. 
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h. To tile (repeat) a bitmap inside a shape, scale the fill. 
[image: image57.png]




Note: To see all of the handles when working with large fills or fills close to the edge of the Stage, choose View > Work Area.
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You can use the Eye Dropper tool to copy fill and stroke attributes from objects.




To use the Eyedropper tool:

1. Select the Eye Dropper tool and click the object whose attributes you want to copy. (When you click a stroke, the tool automatically changes to the Ink Bottle tool. When you click a filled area, the tool automatically changes to the Paint Bucket tool)

2. Click the object that you want to apply the new attributes to.





Using the Eyedropper tool to select a bitmap fill:

Rather than painting with a fixed color or gradient you can paint using a bitmap image. A very important special use of the eyedropper tool is to select bitmap fills.

1. Place a bitmap image on the stage. Either drag it from your symbol library (Ctrl+L or Window > Library) or import a bitmap image from a file (Ctrl+R or File > Import).

2. Make sure the imported bitmap is selected. (If not: click on it with the Arrow tool).

3. Press Ctrl+B to break apart the image.

4. Select the Eye Dropper tool and click on the image.

You will now see a miniature of your image in the Color Fill tool box. Use the Paint Bucket tool to apply the bitmap fill to an object. (Note: you can apply the fill to any filled object as well as any closed outlined area.)
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The Pen tool is the only tool in the Flash toolbox that doesn't resemble a tool from everyday life. Although the tool symbol looks a lot like an ordinary pen it works quite a bit different.

The purpose of the Pen tool is to allow you to draw precise paths as straight lines or smooth, flowing curves.

You can create straight or curved line segments and adjust the angle and length of straight segments and the slope of curved segments afterwards.

There are two methods for drawing with the Pen tool:

1. Click to create points on straight line segments

2. Click and drag to create points on curved line segments. 

Each method is described below.





To draw straight lines with the Pen tool:

1. Select the Pen tool. 

2. Click on the stage to set points, and watch how Flash automatically connects points as you set them.
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3. To complete the path leaving it as either an open or closed shape. Do one of the following: 

3a. To complete an open path, double click the last point or click the Pen tool in the toolbox, or Control-click (Windows) or Command-click (Macintosh) anywhere away from the path. 

3b. To close a path, position the Pen tool over the first anchor point. A small circle appears next to the pen tip when it is positioned correctly. Click to close the path, and watch how Flash automatic adds a fill once the path becomes a closed outline.
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To draw curves with the Pen tool:

First look at this 4 step example:

An example of curve drawing with the pen tool
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1. Select the pen tool and click twice to create a straight line - on the second click keep the mouse button down.

2. Drag the mouse towards yourself - which will cause the control line to appear. The control line is pulled in the one end and has a drag point in the other end.

3. Move the mouse from side to side (B) and forward and down (A)- still holding down the button, and see how the drag point moves accordingly.
The drag point defines both how much and in which direction the initial straight line is dragged.

4. When the curve on the initial straight line is shaped the way you want it release the mouse button, and the end result appears while the control line disappears.
[image: image64]
Create an opening page in Flash that will animate on your web page.

1 Open flash
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The Stage, Toolbar & Timeline should  appear (see below)

Import to Library… four computer pictures from the Graphics Computer folder
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First graphic click on Library graphic 1 and drag onto stage =  place this in one corner 


You will animate this by moving it to a new position at the 30th  frame…
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At Frame 30 click Insert – Timeline Keyframe (or Right Mouse Click on the frame and select Keyframe

Double click on the layer and re name this Clip 1

Next click on the first frame of Layer Clip 1 and insert Timeline Create Motion Tween.



Your Flash should look like this…


The Timeline viewer (red) shows the end point.


Drag your image (Clip 1) the bottom of the page then hit Enter or Control play.
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 If your Clip moves you have made your first flash animation. 

Insert a new layer for Clip 2

Clip 3 and Clip 4

Repeat for each of the next clips and make 

them move to opposite corners.

Save your flash file as flash1.fla (you can work on it add and improve it in the future)

Export your flash movie as movie1.swf

(This will play on a web browser – in Dreamweaver select where you want to place your movie, from Insert media – click on Flash)





You can resize the file and you can play the movie

 Save Dreamweaver and preview in browser.
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Having created animations we can also create shapes

Create a new file in Flash

Draw a rectangle in one corner

Click on Frame 30 and insert a Keyframe


At the end point draw a circle in another corner fill with a different colour.


Click on Frame 1 


and Insert Timeline, Create Shape Tween


Play the movie your square should dissolve into a ball…

Finally go back to your flash1.fla and make each clip rotate as they move, type WELCOME and make this rotate into place, add extra keyframes at the end of each clip to let them stay on screen a bit longer for clients to read

To rotate a bitmap image click on frame 1 then…
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Select Rotate from the Properties box Select CW (Clockwise and 3 rotations)

With WELCOME, move the text out of the stage and bring it in rotating to the center of the stage

Your screen should look like this (Extra space added)
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Click on frame 30 and from Insert Timeline click on Keyframe (this will put a reference point for your animation) 

Now move the picture to a new location (the opposite corner)

Double click on the layer to name it 




Keyframe 30

[image: image72.wmf]
Click on  keyframe 1 and from Insert click on Create Motion Tween (Tween – In-between)

A solid line with an arrow will appear

From Control  Click on Play  (Hit Enter Key)

Your image should move to a new location

You can experiment with this by rotating the image as it moves or changing its size

For now save your first flash as Flash1.fla to your folder.

Insert a new layer and repeat the actions above putting your new image onto the stage and moving it at keyframe 30

[image: image73.wmf]
Name the layer 

Click on keyframe 30 for that layer 

Insert a Keyframe then move your image to a new location

Create a motion tween for this NOTE Click on keyframe 1 first
See if the images move   (if you got a dotted line in your Create Motion Tween) you have NOT done this correctly.

Now add two more layers and two more pictures

Include a fifth layer make this text with the words WELCOME and animate this

You should have an animation like the one shown below.

[image: image74.wmf]
If it works click on File Export Movie and save your file as Welcome.swf


Try to make your images rotate, change shape or do something different.

Try it in a web browser (Don’t worry if it keeps repeating we will fix this next lesson)

A Flash Example

This End this session
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